Back to overview
Downtime
Personal Stat Endpoints and Account & Community Stat Endpoints are down
Apr 14 at 04:35pm BST
Affected services
Personal Stats
Accounts, Icon Packs & Community Stats
Resolved
Apr 14 at 04:37pm BST
Personal Stat Endpoints recovered.
Affected services
Personal Stats
Updated
Apr 14 at 04:36pm BST
Account & Community Stat Endpoints recovered.
Affected services
Accounts, Icon Packs & Community Stats
Created
Apr 14 at 04:35pm BST
Personal Stat Endpoints and Account & Community Stat Endpoints went down.
Affected services
Personal Stats
Accounts, Icon Packs & Community Stats